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ADD SOUND TO YOUR SITE

ANIMATION, STILL IMAGES and

video dominate a Web where sound

and music are almost forgotten media. Beyond

MP3 sites of questionable legality, there’s little

to listen to when you’re cruising the Net, but it

needn’t be that way at all.When used wisely

and coded correctly, sound can enhance the

way you use the Web.What’s more, it’s far 

easier to do than you might think.

Sound capabilities aren’t built directly into

Web browsers, but most do come with multi-

media plug-ins that will play a range of for-

mats by default. Both Internet Explorer and

Netscape are capable of using QuickTime to

play sound.The formats supported split into

two basic types. Audio samples are digital

recordings of sound and can generate large

files. MIDI files, on the other hand, don’t con-

tain any actual sound data. Instead they store

musical information that can be read by the

synthesiser on a sound card or a virtual synth

such as the one built into QuickTime.

In either case, the procedure for adding

sound to your page is a fairly straightforward

one using basic HTML. It’s more difficult to

decide when to use sound, how to prepare

your media and which format to use.

WAYS TO USE SOUND
The worst uses of sound on the Web are also

the most prevalent. It’s very easy to embed a

MIDI file in a page so that it automatically

plays as the site loads. If the quality of the

arrangement in the music file is good and it’s

appropriate to the content on the page, then

this might be excusable – but too often these

criteria aren’t met. It’s even more annoying

when there’s no way provided to stop playback

and the file is set to loop infinitely.Though 

less widespread, auto-triggering long sound

samples when a page loads is an even more

irritating practice. Digital audio files eat band-

width for breakfast and there are far more ele-

gant uses for them than imposing them on

reluctant listeners.

Ambient sounds attached to sections of

your site can be used as aural navigation aids,

button “clicks” give your audience the sense

that they’re using a proper desktop application

➔

HEAR HERE Use Flash to compress and stream imported sound files using MP3 technology

2Double-click on the new button to go to

Symbol Editing mode. In the Timeline, add a

new Layer by clicking on the + icon. Double-click

on the label for the Layer and rename it “Sound”.

Place the cursor under the Down position in the

Sound Layer and go to Insert > Keyframe.

3Add further Keyframes to the Over and Down

states of Layer 1 as well. Select the new

Keyframe in the Sound Layer. Go to Window >

Common Libraries > Sound. In the Sound Library

locate the sound labelled “Plastic Button”.

4Drag and drop the sound to the stage. Make

sure the waveform has appeared in the Down

Keyframe of the Sound Layer. Go to Control > Test

Movie to hear your button in action.

1Create a new button in Flash 5 by drawing a

shape. Select it, then go to Insert > Convert to

Symbol. Name the button “SoundBtn” and choose

Button as the symbol type before clicking OK to

dismiss the dialogue box.

It’s all gone quiet on the Web, but it doesn’t have to be

that way. Karl Hodge investigates ways to put pop in your pages

and noise on the Net. 

HOW TO

Visit www.heavy.com to get an idea of the extra dimension that sound can add to your site.

When used wisely and coded correctly, sound can
enhance the way you use the Web
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KEEP IT SIMPLE
Avoid using MIDI files that have huge, complicated arrangements
as the quality of sounds generated can vary massively from one
user’s machine to another. Go for simple string and piano
arrangements and avoid files with lots of guitar and drums.

KEEP IT IN TIME
The speed of a sound loop is measured in beats per minute. This is
useful to know because you can mix and match samples that
have the same “bpm”. A good shortcut in Flash is to use samples
that run at 120bpm – this makes it easier synchronise the beats
in a sample to individual frames.

KEEP IT SMALL
You already know that samples and sound files that are triggered
as a page loads should be small in size. A good guide is to keep
them below 50k if possible – 30k is the ideal.

TIPS
PHOTOSHOP MASTERCLASS 
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and minimal music can replace time-consum-

ing splash pages to dramatic effect.

The most effective use of sound starts with

the principle that bandwidth is as precious as

your audience’s patience. Good effects can be

achieved using the most simple of ambient

sound loops. A couple of seconds of “real”

sound, repeated over and over, can be far more

efficient than a fully orchestrated version of

the end theme from Star Wars.

Aesthetic concerns must come first, and in

the same way as you take care to make sure

you use a colour scheme that doesn’t clash,

you should be careful that your use of sound in

pages is never intrusive.

COMPRESSION AND OPTIMISATION
One of the main problems of including sound

in Web pages is the potentially excessive

download size of digital audio files. A solution

to the problem of accessing media files quickly

over the Net has been to combine aggressive

file compression with “streaming”.

Streaming is a method that enables you to

listen to (or watch) a media file as it down-

loads. Net protocols send files as “packets” or

sections of data that are inappropriate for con-

tinuous playback. Although this is effective, it’s

only practicable for specific uses, like radio

broadcasting and previewing files at a lower

quality before committing to a lengthy down-

load. On the Mac, QuickTime and RealAudio are

the main contenders in audio streaming.

Our primary concern here is in integrating

sound and music with Web pages, which is

best achieved by using a combination of file

compression and careful optimisation. Most

digital audio formats have some form of com-

pression algorithm, including WAV and AIFF

files, the two most popular formats for audio

samples. Compared to the controversial MPEG

3 format, though, the files generated are still

pretty large.These formats are best used when

you need to use sounds of very short duration

“inline” within a browser, to accompany a but-

ton click, for example.

You can optimise the audio further by

reducing the sample frequency. As a guideline,

CD-quality audio is sampled at around 44kHz.

Audio sampled at 11kHz takes up a quarter of

the space but is adequate for many uses.

MPEG audio compresses sound files to sizes

which are far smaller than the equivalent data

space taken up by a CD audio track. In simple

terms, the compression works by calculating

which parts of a sound our ears will automati-

cally “fill in”, and removing them. MPEG Layer 3,

the most recent revision of the format, can

make sound data up to 12 times smaller 

without a significant reduction in the 

perceptual quality.

The latest versions of the Shockwave Flash

plug-in are capable of playing MP3 audio – so

you can embed longer audio sequences into

pages as part of a Flash movie with relative

ease.You can also use Flash to “loop” shorter

6Go to Modify > Movie and set the frame rate

to 10fps.This will help us synchronise the

sounds. Select the first frame of the Soundtrack

Layer, then drag and drop an instance of the sound

“mfloop1.wav” to the stage.

5 To create a streaming soundtrack, you need to

start with a sample that can be looped.

Return to the main stage then go to the File menu

and Import “mfloop1.wav” from the cover disk.

Make a new layer labelled “Soundtrack”.

7Go to the timeline and place Keyframes in

frame 30 of both layers. Select Keyframe 30,

go to Window > Actions and insert a Stop action.

Select the sample in the Timeline again 

and in the Loops section of the Sound Panel,

type in “32”.

8 Select the original “mfloop1.wav” sample in

the Library, then click on the Properties icon

at the bottom of the panel. Under Compression

choose MP3 and leave the remaining settings at

their defaults. Click OK, then go to Control > Test

Movie to hear the playback.

Audio resources

An archive of sound loops in a great package – that’s mediahead.com

FLASHKIT – The defini-
tive collection of Flash
tutorials, pre-fab files
and sound effects on
the Web. A site that
must be bookmarked.
www.flashkit.com

MEDIAHEAD – Mainly
the work of one man,
this well-designed
archive site gives you
access to a huge batch
of royalty-free sound
loops for use in any
multimedia project.
www.mediahead.com

SAMPLENET – Future’s
own sample site has a
collection that dates
back to 1997. Trawl
through the categories
to find breakbeats,
sound effects and drum
loops. www.
samplenet.co.uk

MAC MUSIC – If you’re
serious about making
noise with your Mac,
you’ll need this site to
check out all the latest
software and hardware
news. There are forums

and tutorials too.
www.macmusic.org/
eng/

MIDIFARM – The com-
pact MIDI, or Musical
Instrument Digital
Interface, file is ideal
for distributing music
on the Web – but 
quality is hard to come
by. At the MIDI Farm
you can search for free
music or download 
programs to make your
own with. www.midi-
farm.com
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ADD SOUND FILES How to do this in HTML

1First you’ll have to locate some sounds or

music. A good source for original, royalty-free

MIDI files is Planet MIDI at www.

planetz.net/midi/ For sound samples try

www.samplenet.com. Save the sound file to the

same directory as your HTML document.

2For a direct method of placing sound files in

Web pages, use Simple Text to type in

<BGSOUND SRC=”file”> after the <BODY> tag.

The item “file” should be replaced by the path to

the sound file you want.The file can be a short

sound sample in WAV or AIFF format, or a MIDI file.

3You can specify how many times the sound

plays by using the “loop” attribute. Add it to

the code like this:

<BGSOUND SRC=”file” LOOP=”1”>

“LOOP” can be any number from -10000 to 10000

– although for higher numbers it’s easier to just

type “infinite”.

4For a more controllable solution, you should

use the <OBJECT> tag.This is used to embed

media of all types and can be combined with

JavaScript so that sounds can be triggered by a

button.This script loads a sound with a unique ID;

<OBJECT ID=”BgSound” DATA=”bgsound.wav”

TYPE=”audio/x-wav”> <PARAM

NAME=”autostart”VALUE=”true”> </OBJECT>

MAKE IT MONO
Use Mono samples in Flash. This is not only good sense from a
bandwidth point of view, but it also prevents channel clashes. Use
the effects section to create stereo separation and cross-channel
effects if desired.

MIX ‘N’ MATCH
Try using a combination of a short drum-loop sample with a cou-
ple of longer synth chords in the same key. In Flash you can go to
the effects section by choosing Edit in the Sound Panel and place
“Fade-In” and “Fade-Out” effects on the note, which can generate
interesting sounds as samples mingle with each other.

MAKE IT MORE
If you have two samples of equal length and beats per minute,
say two seconds long at 120bpm, triggering the second sample a
bar or three bars after the first will give the illusion of a longer,
more intricate musical sequence. A bar is four full musical beats.

TIPS

Sites that use sound
Finding sites that use sound well is difficult – they’re few and far between. This
collection shows what’s possible when you put your mind to it.

Atomfilms.com has great examples of how to synchronise sound to actions.

DIGIMASK – Although Digimask’s
main business is promoting 3D clones
for use as avatars on the Internet
and in games, the site is a great

example of good sound design. Made
in Flash, buttons respond with an
audible click and sections feature
intricate sound loops.
www.digimask.com

ATOM FILMS – Some of the best exam-
ples of the proper use of audio come
from the world of Flash animation.
Check out the way that dialogue and
music are synchronised to actions.
www.atomfilms.com

BEATNIK – A strange composition and
playback tool aimed at the Web,
Beatnik hasn’t caught on as yet. Still,

the site and software are worth
checking out. Download the plug-in
from the site to hear it in all its glory.
www.beatnik.com

MOLOKO – One of the hit parade’s
more creative combos is about to
launch an album of remixes called “All
Back to the Mine”. The micro-site
accompanying the release has rollover
buttons that squeak, auto-loading
sound loops and streaming RealAudio
rarities. www.moloko.co.uk

HEAVY.COM – Along-side animated
“shows”, videos and games that make
use of music and dialogue in a variety
of formats, the navigation system
uses Flash to stream MP3s at you.
www.heavy.com
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sections of audio, or even combine multiple

loops to create a more complex soundtrack.

As ADSL and cable access move ever closer

to becoming the standard way to suck infor-

mation from the Web, compressing small

audio files will cease to be as problematic.

Sites such as heavy.com, a site with a continu-

ous streaming soundtrack and integral audio

in discrete sections, shows the way towards

the broadband Internet of the future.

POTENTIAL FOR PROBLEMS
Bandwidth isn’t the only problem that design-

ers who are itching to put sound into their

pages have to face. Because there’s no stan-

dard method for placing sound on the Web, it’s

not easy to make your pages compatible with

every browser and every platform. If you’re

building a site that’s aimed at a specific audi-

ence then you can make an educated guess

about the kind of set-up your users are likely

to have – including which plug-ins they may

have installed.

If you’re building a site for Mac-based musi-

cians you won’t need to worry that the

embedded AIFF sound files you’ve used may

not play back on many Windows machines.

You may want to think about going with

Windows WAV format files if your site is aimed

at a more general audience – particularly as

QuickTime can handle them perfectly well.

The third option is to use the lesser-known

AU format. Originally starting its life on UNIX

systems, AU is supported by the default audio

plug-in that ships with Netscape and should

claw back some of its lost popularity as Mac

OS X gains ground.

CODE WAR
The problems don’t end with sound formats.

Both Netscape and Internet Explorer support

different methods for embedding multimedia

content. Microsoft introduced the <DYNSRC>

and <BGSOUND> tags in IE4, both of which

can be used to play back sound files.

Netscape’s preferred method is the

<EMBED> tag – a more general container for

plug-in content.While <EMBED> is supported

by all the most current browsers, the smart

money is now on the <OBJECT> tag.This is

more or less the same as <EMBED> but it’s

endorsed by the World Wide Web Consortium,

the committee that decides Web language

standards.The other methods are likely to be

phased out over time.

Flash is a good cross-platform solution in

most cases because the plug-in has its own

sound playback routines built in and works in

a very similar way on both Windows and Mac

browsers. Add this to its MP3 compression

capabilities and you’re laughing.

If you’ve got a microphone handy, why not

record those guffaws and feature them on

your website? MF

The latest versions of the Shockwave Flash plug-in
are capable of playing MP3 audio
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